Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: 66 Mustang 289 1G alternator wiring


PETERBOROUGH, ONT

Status: Offline
Posts: 903
Date:
66 Mustang 289 1G alternator wiring
Permalink  
 


I thought I had the wiring all sorted out but my alternator still isn't running.  (I don't think I am repeating an old thread but maybe I am forgetting again.)

I bought a Haynes repair manual and read it and I've watched a lot of videos on-line. Most deal with switching to a 1 wire.  Of course I read my little 'How to wire your Hot Rod'.

 I found an English guy named Edd China and in his youtube video "Workshop Diaries 25" he explores the oddities of a 66 Mustang 289 alternator and the various ways it was wired in 66:

https://www.youtube.com/watch?v=8KozOU21GqE

So I tried a few different things without success.  Although I still don't have my alternator running, I am very familiar with my regulator and alternator now so I am learning.

I've been trying to solve this issue for a long time.  My wires under the dash are improved but still a mess. I am ordering a new harness from Rebel wires next when I have enough money.

 

I think the regulator 'A' goes the the alternator 'Battery' terminal.

I think the regulator 'S' goes to the alternator stater terminal.

I think the regulator 'F' goes to the alternator Field terminal.

I think the regulator 'I' goes to the ignition. I bolted it to accessory because I can't get at the coil terminal. It is encased in rubber.

So --- still no luck.

Tomorrow I will try inserting a lightbulb between the ignition and the regulator 'I' terminmal.  I understand that was once referred to as an idiot light in the dash to indicate the alternator was excited.

Everything is grounded and the alternator and regulator were checked at the shop and they are both good.

I have given this problem a lot of effort and time with no luck.

If this doesn't work tomorrow, I think it will be time to take it to a shop. I can't be running on my battery forever.

Hopefully I will find out what I was doing wrong.



__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.



Create your own FREE Forum
Report Abuse
Powered by ActiveBoard